[Return to main site] 

Bean - Unable to upload .gcode or .gco files


#1

Hi all,
I tried to upload a .gcode file to print. It ended with an internal server error message:


Upload failed

Could not upload the file. Make sure that it is a GCODE file and has the extension “.gcode” or “.gco” or that it is an STL file with the extension “.stl”.
More

Internal Server Error

The server encountered an internal error and was unable to complete your request. Either the server is overloaded or there is an error in the application.

I tried to generate the file with three different slicing programs, with the same result.
Uploading of slice images in a .zip file is working, .gcode or .gco - no joy.
How to solve this?
With regards, Rob.


#2

Since the Bean operates by illuminating images onto the screen slice by slice, gcode files have no meaning to the printer. Only zips of slice images have the information necessary to be displayed and printed.

What are you trying to do with the gcode files?


#3

Hi jkao
Thanks for your reply. Of course I was exploring all capabilities of the new printer.
The output of the three main slicing programs is gcode, so I tried to upload these files.
The Bean error report gave the impression that .gcode or .gco files were usable.
Soo… thanks for the enlightenment.
Now I have to figure out how to obtain slice images from programs like Craftware, Cura or Octoprint. :slight_smile:
With regards, Rob.