[Return to main site] 

Can’t control Bean printer


Seems like I have the same problem.
Leds on, LAN H/W interface seems to connect.
No control panel, no fan.



hi guys
i got replay from kudo after i tell them what i did ( update but not working )

they said it could be mega or the ramps

and send me a youtube link in how to disassembly bean ( new video you can see it )
to remove the mega2560
and reset it and do the update again

“you need to do this to reach reset button”
if thats not work they will replace the mega for me ( they said it in the mail )

i will try to this tomorrow to see if that works or not


Hi all,

I had an answer from kudo3d, but I had no solution yet…
@MrEbda3 I hope you will solve the problem with this reset.

@nnatsios welcome to the unlucky bean club.


And this is what my brick looks like from the inside.
Red pi & mega.
Wonder what I can do about it.


Hi, identical to mine…This evening they answered me, they think that the problem is the mega 2560, they made me disassemble and test it (as MrEbda3). My board is actually dead, I hope this is the only problem. I’m waiting the reply, until now they have been collaborative…Did you wrote to Kudo? more or less I have an answer a day


@nnatsios ps: one thing they were very specific about is “Please open the back panel and check if there is a gap between raspberry pi and the heat sink.” so be careful, I think if the PI touches the heat sink, something can go very badly :scream:


Finally got it to work!
Had to reflash the Rpi SD with new image that support provided.
Now I have (seemingly) working Bean!
Will start with home calibration and printing the kudo test file.
Thank you all and good luck with your prints!


my main problem is
the mega keep disconnecting/ reconnecting to the pc

so i guess it is dead unit or something

and kudo said they will replace it to me !

let’s wait until then :slight_smile:


as i was expected
they said to me my warranty for boards expired
and they will not replace it for me

i should do that :slight_smile:


I’ve had this issue for the past 3 weeks, failed Mega2560, Rasp Pi issue and possibly another ramps issue along with black blotches on the LCD. All of this after two weeks of usage. Kudo3D basically responded and said tough luck. As an early backer, you paid less then what is cost to make the printer. The number of DOA units are adding up slowly on the facebook groups also.


same problem here. did you solve it?


Hi, after hearing kudo assistance directly, they made me disassemble the printer by following a video, and extract the mega 2560. I tried to update the firmware but I could not see the board in the port, so the board is dead. they will replace me card and ramps in about 2 weeks (because they need to send some inventory to UK first). The RPI seems ok, I hope the problem are just the boards and if so it’s not a big problem, you can also buy it on amazon for about 20/30 € and have it in 2 days.

I’m more worried about LCD and uv lamp … but for that I have to wait at least to be able to print something :pensive:


Kudo3d is not going to replace anything. Mine’s been going on 4 weeks and now they went rogue.
The corporate attitude just doesn’t get it.


The problem come from a short with heatsink assembly, this make bad contact with raspberry usb pins.in worst cases RAMPS or Mega is damaged for this issue. I recommend carefully dissembled the printer with kudo video. Until you can move the raspberry, I used electrical tape to protect the USB port contacts.

After do this, I have not got any problems,


Hi all. I have the same problem and I can not get it to work. Bean looks like a great machine, but I’ve never been able to use it.
The serial port does not work and I can not print or control Bean. I have read in the Forum and I have tried to update the firmware of MEGA2560, but being a Chinese copy I can not connect from my PC. I bought a new MEGA and updated the FIRM to version 20181015 but it still does not work.
There can only be three options: the RAMPS, the RPI or the SD of the RPI. Please I need help to be able to start BEAN.

If you send me a copy of the OS from the SD, I can try to update.
There is no short circuit in RPI with heatsink.
The power supply of the RAMPS was short-circuited by the metal bridges and I changed them by protected cable: PHOTO

Thank you